titulo.jpg

Home

Principal

Assinar

 

Dicas

Excel

Word

Outlook

Office/VBA

Suplementos

Vídeos

Outros

Busque neste site:

Loading
 

Somar Células num Intervalo

Última atualização: 06/12/2011

Introdução

Soma Cumulativa

Somar os n Maiores ou Menores Valores

Soma Condicional de Células

Somar Células com Base em Múltiplos Critérios

Referências

 

Introdução

Um dos maiores objetivos de uma planilha eletrônica é determinar totais e subtotais. O Excel possui várias funções para executar somas, inclusive baseadas numa ou mais condições. Esta página possui vários exemplos de como se fazer isso.

 

Soma Cumulativa

Observe a tabela abaixo:

Observe a coluna C. A fórmula em C3 é:

=SOMA(C$3:C3)

Como a referência do intervalo está relativa numa parte e absoluta em outra (se não entendeu isso, clique aqui), ao arrastar a fórmula até C14, a fórmula de soma ajustará automaticamente para o que chamamos de soma cumulativa. À medida que são preenchidos os valores de quantidade dos meses, a soma cumulativa é computada.

Se você quiser que a soma cumulativa seja mostrada somente se a quantidade de um mês estiver preenchida, use:

=SE(B3<>"";SOMA(B$3:B3);"")

 

Somar os n Maiores ou Menores Valores

Veja a tabela abaixo:

No intervalo A3:A200 há vários números.

Para somar os 5 maiores valores desse intervalo, use a fórmula:

=SOMA(MAIOR(A3:A200;{1;2;3;4;5})) (fórmula matricial)

Fórmulas matriciais devem ser entradas com Ctrl+Shift+Enter. Se não sabe sobre fórmulas matriciais, clique aquii.

Se quiser somar os 5 menores valores desse intervalo:

=SOMA(MENOR(A3:A200;{1;2;3;4;5}))

Se quiser os 20 maiores intervalos, ao invés de povoar o vetor de números de 1 até 20, use a função INDIRETO:

=SOMA(MAIOR(A3:A200;LIN(INDIRETO("1:30")))) (fórmula matricial)

Se quiser saber mais sobre a função INDIRETO, clique aqui.

Obviamente, se quiser os 20 menores intervalos, troque a função MAIOR por MENOR.

 

Soma Condicional de Células

É possível somar células de um intervalo que atendam um critério específico, como por exemplo: Somar todas células da coluna B em que sua célula vizinha na coluna A seja igual a Felipe. Este seção apresentará alguns exemplos.

A função SOMASE retorna uma soma baseada num critério. Essa função pode ser usada com 2 ou 3 argumentos. Veja o exemplo abaixo, em que a função se apresenta na forma de dois parâmetros:

A fórmula, por exemplo, para obter todos os valores positivos, é:

=SOMASE(A3:A11;">0")

Como podemos ver, o primeiro parâmetro é o intervalo de busca, e o segundo parâmetros é a condição a ser satisfeita para que a célula entre no somatório.

O SOMASE se assemelha ao CONT.SE quando usado apenas com dois parâmetros. Recomendo fortemente a leitura da página Contar Células num Intervalo antes de prosseguir porque lá há vários exemplos da função CONT.SE que se aplicam ao SOMASE com 2 ou 3 parâmetros.

Veja abaixo um exemplo muito utilizado quando se usa o SOMASE com três critérios:

Em E18:

=SOMASE(A17:A25;"Felipe";B17:B25)

Nessa forma de SOMASE, a parte azul é o local da busca em que o critério (Felipe) será aplicado. A parte verde, correspondente da azul, será o intervalo que possui os valores. Em outras palavras, se a A17="Felipe", adiciona-se B17 à soma. Se a A18="Felipe", adiciona-se B18 à soma, e assim por diante até o final do vetor (A25).

A fórmula em E21 é:

=SOMASE(A17:A25;"<>Felipe";B17:B25)

Vale ressaltar que a coluna de procura e a de valores não precisam ser necessariamente adjacentes.

 

Somar Células com Base em Múltiplos Critérios

Existe uma função que foi introduzida a partir do Excel 2007 para somar células que atendam múltiplos critérios (por exemplo: somar células da coluna C cuja coluna A seja Felipe e coluna e coluna B seja maior que 100 ) chamada SOMASES. No entanto, recomendo fortemente não usá-la, mas usar uma das funções mais versáteis do Excel, que é a SOMARPRODUTO Clique aqui para ver o artigo de SOMARPRODUTO.

 

Referências

John Walkenbach: Microsoft Excel 2010 Bible

Contar Células num Intervalo

Fórmulas Matriciais

SOMARPRODUTO

Para baixar um arquivo de exemplo pronto, clique aqui.

 

---

Site de Felipe Costa Gualberto.

Belo Horizonte, Brasil, 2009-2013.

felipe@ambienteoffice.com.br