titulo.jpg

Home

Principal

Assinar

 

Dicas

Excel

Word

Outlook

Office/VBA

Suplementos

Vídeos

Outros

Busque neste site:

Loading
 

Contar Células num Intervalo

Última atualização: 05/12/2011

Introdução

Exemplos de Contagem de Células num Intervalo

Contagem Condicional de Células

Contar Células com Base em Múltiplos Critérios

Elemento Mais Frequente numa Lista

Contar Número de Ocorrências de Texto Específico

Contar Quantidade de Registros Distintos Numa Lista

Referências

 

Introdução

O Excel é uma poderosa ferramenta para contar células, baseados até com uma ou mais condição. Esta página possui vários exemplos de como se fazer isso através das funções do Excel.

 

Exemplos de Contagem de Células num Intervalo

Observe a figura abaixo. Ela contém vários exemplos de contagem de células num intervalo, dependendo de sua natureza:

As fórmulas usadas são:

Total de células: =LINS(A2:B11)*COLS(A2:B11)

Células em branco: =CONTAR.VAZIO(A2:B11)

Células preenchidas: =CONT.VALORES(A2:B11)

Valores numéricos: =CONT.NÚM(A2:B11)

Não possuem texto: =SOMA(SE(É.NÃO.TEXTO(A2:B11);1)) (fórmula matricial)

Células texto: =SOMA(SE(ÉTEXTO(A2:B11);1)) (fórmula matricial)

Valores lógicos: =SOMA(SE(ÉLÓGICO(A2:B11);1)) (fórmula matricial)

Erros: =SOMA(SE(ÉERROS(A2:B11);1)) (fórmula matricial)

Erros #N/D: =CONT.SE(A2:B11;"#N/D")

Erros #NULO!: =CONT.SE(A2:B11;"#NULO!")

Erros #DIV/0!: =CONT.SE(A2:B11;"#DIV/0!")

Erros #VALOR!: =CONT.SE(A2:B11;"#VALOR!")

Erros #REF!: =CONT.SE(A2:B11;"#REF!")

Erros #NOME?: =CONT.SE(A2:B11;"#NOME?")

Erros #NÚM!: =CONT.SE(A2:B11;"#NÚM!")

As fórmulas matriciais devem ser entradas na Planilha com Ctrl+Shift+Enter. Para saber mais sobre fórmulas matriciais, clique aqui.

Vale ressaltar que as fórmulas de contagem de erro não vão funcionar para a versão do Excel em inglês, por exemplo, já que o erro #NOME? é #NAME?. Você poderia corrigir esse erro forçando o erro, como por exemplo: =CONT.SE(A2:B11;NomeInesistente).

 

Contagem Condicional de Células

Considere um intervalo fictício. As fórmulas abaixo são vários exemplos de como se fazer uma contagem baseada num critério.

=CONT.SE(Intervalo;12) - Retorna o número de células que contém o valor 12.

=CONT.SE(Intervalo;"<0") - Returna o número de células de valor negativo.

=CONT.SE(Intervalo;"<>0") - Returna o número de células diferentes de 0.

=CONT.SE(Intervalo;">5") - Returna o número de células maior que 5.

=CONT.SE(Intervalo;A1) - Retorna o número de células de valor igual ao de A1.

=CONT.SE(Intervalo;">"&A1) - Retorna o número de células maior que o valor de A1.

=CONT.SE(Intervalo;"*") - Retorna o número de células que contém texto.

=CONT.SE(Intervalo;"???") - Retorna o número de células de texto que contém exatamente três caracteres.

=CONT.SE(Intervalo;"casa") - Retorna o número de células que possui texto exatamente igual a casa (não diferencia maiúsculas de minúsculas).

=CONT.SE(Intervalo;"*casa*") - Retorna o número de células que possui o texto casa dentro de todo texto da célula (não diferencia maiúsculas de minúsculas).

=CONT.SE(Intervalo;"A*") - Retorna o número de células que começam com a letra a (não diferencia maiúsculas de minúsculas).

=CONT.SE(Intervalo;HOJE()) - Retorna o número de células que contém a data atual.

=CONT.SE(Intervalo;">"&MÉDIA(Intervalo)) - Retorna o número de células cujo valor é maior que a média.

=CONT.SE(Intervalo;">"&MÉDIA(Intervalo)+DESVPAD(Intervalo)*3) - Retorna o número de células cujo valor excede três desvios padrões acima da média.

=CONT.SE(Intervalo;3)+CONT.SE(Intervalo;-3)+CONT.SE(Intervalo;5) - Retorna o número de células contém o valor 3, -3 ou 5.
Alternativa: =SOMA(CONT.SE(Intervalo;{3;-3;5})) (fórmula matricial)

=CONT.SE(Intervalo;VERDADEIRO) - Retorna o número de células que contém o valor lógico VERDADEIRO.

=CONT.SE(Intervalo;VERDADEIRO)+CONT.SE(Intervalo;FALSO) - Retorna o número de células que contém o valor lógico VERDADEIRO ou FALSO.
Alternativa: =SOMA(CONT.SE(Intervalo;{VERDADEIRO;FALSO})) (fórmula matricial)

=CONT.SE(Intervalo;"#N/D") - Retorna o número de células que possui o erro #N/D.

 

Contar Células com Base em Múltiplos Critérios

Existe uma função que foi introduzida a partir do Excel 2007 para contar células que atendam múltiplos critérios (por exemplo: contar células com valores entre 10 e 100) chamada CONT.SES. No entanto, recomendo fortemente não usá-la, mas usar uma das funções mais versáteis do Excel, que é a SOMARPRODUTO. Clique aqui para ver o artigo de SOMARPRODUTO.

 

Elemento Mais Frequente numa Lista

Observe a figura abaixo:

Para saber qual é o termo mais frequente numa lista, use:

=ÍNDICE(A18:A27;CORRESP(MÁXIMO(CONT.SE(A18:A27;A18:A27));CONT.SE(A18:A27;A18:A27);0)) (fórmula matricial)

Para saber quantas vezes esse termo aparece:

=CONT.SE(A18:A27;D18)

 

Contar Número de Ocorrências de Texto Específico

Observe a figura abaixo:

As fórmulas são:

Vezes que 'alpha' aparece:

Não diferenciando maiúsculas de minúsculas: =CONT.SE(A31:A41;B31)

Diferenciando maiúsculas de minúsculas: =SOMA(SE(EXATO(A31:A41;B31);1))

Células que consta o texto 'alpha':

Não diferenciando maiúsculas de minúsculas: =CONT.SE(A31:A41;"*"&B31&"*")

Diferenciando maiúsculas de minúsculas: =SOMA(SE(NÚM.CARACT(A31:A41) - NÚM.CARACT(SUBSTITUIR(A31:A41;B31;""))>0;1)) (fórmula matricial)

Vezes que aparece o texto 'alpha' em todas as células:

Não diferenciando maiúsculas de minúsculas: =(SOMA(NÚM.CARACT(A31:A41)) - SOMA(NÚM.CARACT(SUBSTITUIR(MAIÚSCULA(A31:A41);MAIÚSCULA(B31);"")))) / NÚM.CARACT(B31) (fórmula matricial)

Diferenciando maiúsculas de minúsculas: =(SOMA(NÚM.CARACT(A31:A41)) - SOMA(NÚM.CARACT(SUBSTITUIR(A31:A41;B31;"")))) / NÚM.CARACT(B31) (fórmula matricial)

 

Contar Quantidade de Registros Distintos Numa Lista

Veja nesta página: Registro Distintos, Exclusivos e Duplicados Numa Lista - Contar Quantidade de Registros Distintos Numa Lista..

 

Referências

John Walkenbach: Microsoft Excel 2010 Bible

Fórmulas Matriciais

Registros Distintos, Exclusivos e Duplicados Numa Lista

Somar Células num Intervalo

SOMARPRODUTO

Para baixar um arquivo de exemplo pronto, clique aqui.

 

---

Site de Felipe Costa Gualberto.

Belo Horizonte, Brasil, 2009-2013.

felipe@ambienteoffice.com.br